All 1 entries tagged Adsl

View all 5 entries tagged Adsl on Warwick Blogs | View entries tagged Adsl at Technorati | There are no images tagged Adsl on this blog

October 09, 2006

Getting your Sagem 800 ADSL modem working in Vista RC2

I have figured out how to get Sagem’s awfully supported modem running under Vista RC2, in fact this post is coming directly from Vista. :D

  1. Do not go to Sagem’s (awful) site and download the newest version of the driver – I know it sounds stupid but I could not get that version working at all. Instead stick with the version that came from your ISP.
  2. Locate the “sagem” directory on your ISP driver disc – do not run any of the ISP installer software.
  3. Right-click “Setup.exe” and set the compatibility to “Windows XP SP2” and tick the “run as Administrator” box towards the bottom.
  4. Go ahead and execute “Setup.exe” – let it continue and set everything up, afterwards Vista will prompt you that it has detected new hardware (the modem) and you should install the drivers now. Cancel this dialog and reboot.
  5. Upon rebooting you should have a fully working adsl modem that can be setup for your connection (much easier than in XP) through the network centre. (you might need to unplug-plug the modem to get it to detect give it a few seconds it will work)

Here is the final result:

Sagem Results1Sagem Results2

Edit:
I stopped testing Vista with RC2 and have not had chance to see if the driver support is a little better now we are closing in on the release.

Finally for everyone to try here are the drivers I have got working : Sagem Drivers
(taken offline – defunct)

Looking into the 4.0.5 driver release it seems that they have not said they are compatible with Vista or WinXP 64, unfortunately. Give them a try though, as I have not been able to actually test them for myself.

Here they are : 4.0.5 Drivers

I will soon have Vista RTM myself, maybe then I will do some proper testing and see why these problems exist.

Final Edit (?):
Sagem have finally gotten off their backsides and released an “official” driver that should work fine in Vista (not sure if there are x64 drivers in the package – though I doubt it to be honest)
Without further ado, the much anticipated Vista Drivers :D

Final, Final Edit
The official Sagem drivers now report that they are Vista compatible. Here is the link to find them: Vista Sagem Drivers

I have not tested them so your milage may vary.


August 2020

Mo Tu We Th Fr Sa Su
Jul |  Today  |
               1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31                  

Search this blog

Tags

Galleries

Most recent comments

  • Try the otenet.gr (greek isp) I downloaded a version there that worked perfect on Vista. The origina… by terry on this entry
  • If you are a tiscali customer they have an updated "installation disc" which uyou download and burn … by pothead on this entry
  • Hi all, Anyone still reading this should take note of my "Final Final Edit" paragraph. It seems the … by Leigh Robinson on this entry
  • IT'S NOT THAT ATHIESTS DON'T BELIEVE IN GOD,IT'S JUST THAT CHRISTIANS DON'T BELIEVE IN ATHIEST.YES.I… by JD on this entry
  • Hi all, could someone be so kind and send me a link or directly the driver 2.2.10.20 for my sagem 80… by markus on this entry

Blog archive

Loading…
RSS2.0 Atom
Not signed in
Sign in

Powered by BlogBuilder
© MMXX